VRRP实验——虚拟路由冗余协议


VRRP协议

在多个路由器之间运行
可以虚拟出一个或多个网关地址(虚拟路由器)
从而实现内网不同网段之间的互通

VRRP 的工作过程

运行VRRP的多个路由器之间通过VRRP报文的交互,从而选择出一个最优的路由器,作为Master路由器,主路由器,以后就用这个设备转发数据包。
Master路由器仅仅只有一个,其他的路由器称之为backup路由器,备用
同时,Master和backup路由器,会产生一个虚拟的路由器,也就是一个虚拟的IP地址。

实验拓扑

要求:PC1去往PC2时,走LSW1路径,当LSW1的1口故障时,走LSW2路径。PC2去往PC1时,走LSW2路径,当LSW2的1口故障时,走LSW1路径。利用了浮动路由实现了互相备份,但是故障不能出现在2口,当故障在2口,则浮动路由不能生效。PC1从 SW2走,但是从R1的g0/0/0口出(路由依旧为指向11.0.0.1的下一跳),无法到达PC2。
VRRP实验——虚拟路由冗余协议
VRRP优先级,数值越大越优先。PC1:主LSW1时,优先级为120。备份在LSW2时,优先级为115。
PC2:主LSW2时,优先级为120。备份在LSW1时,优先级为115。

R1配置

配置完环回口地址和两个接口地址后,配置静态路由和浮动路由。

ip route-static 192.168.10.0 255.255.255.0 11.0.0.1
ip route-static 192.168.10.0 255.255.255.0 12.0.0.1 preference 70
ip route-static 192.168.20.0 255.255.255.0 12.0.0.1
ip route-static 192.168.20.0 255.255.255.0 11.0.0.1 preference 70

LSW1配置

vlan batch 10 20 100
interface Vlanif10
ip address 192.168.10.10 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.10.1
vrrp vrid 1 priority 120
vrrp vrid 1 track interface GigabitEthernet0/0/1
vrrp vrid 1 track interface GigabitEthernet0/0/2
#
interface Vlanif20
ip address 192.168.20.10 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.20.1
vrrp vrid 2 priority 115
#
interface Vlanif100
ip address 11.0.0.1 255.255.255.252
interface GigabitEthernet0/0/1
shutdown
port link-type access
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
#
ip route-static 0.0.0.0 0.0.0.0 11.0.0.2

最后一条为默认路由,指向所有网段,通过11.0.0.2下一跳。

LSW2配置

vlan batch 10 20 100
interface Vlanif10
ip address 192.168.10.20 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.10.1
vrrp vrid 1 priority 115
#
interface Vlanif20
ip address 192.168.20.20 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.20.1
vrrp vrid 2 priority 120
vrrp vrid 2 track interface GigabitEthernet0/0/1
vrrp vrid 2 track interface GigabitEthernet0/0/2
#
interface Vlanif100
ip address 12.0.0.1 255.255.255.252
interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
#
ip route-static 0.0.0.0 0.0.0.0 12.0.0.2

LSW3配置

vlan batch 10 20
interface Ethernet0/0/1
port link-type access
port default vlan 10
#
interface Ethernet0/0/2
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20

PC1的网关为192.168.10.1,PC2的网关为192.168.20.1
验证:正常情况下用PC1pingPC2,追踪路径如下图。

VRRP实验——虚拟路由冗余协议

如图所示,走的是192.168.10.10,是LSW1上的路径。
关闭LSW1的g0/0/1接口,主用设备失效,走备用路径。
用PC1pingPC2,追踪路径如下图。

VRRP实验——虚拟路由冗余协议

如图所示,走的是192.168.10.20,是LSW2上的路径。

原创:https://www.panoramacn.com
源码网提供WordPress源码,帝国CMS源码discuz源码,微信小程序,小说源码,杰奇源码,thinkphp源码,ecshop模板源码,微擎模板源码,dede源码,织梦源码等。

专业搭建小说网站,小说程序,杰奇系列,微信小说系列,app系列小说

VRRP实验——虚拟路由冗余协议

免责声明,若由于商用引起版权纠纷,一切责任均由使用者承担。

您必须遵守我们的协议,如果您下载了该资源行为将被视为对《免责声明》全部内容的认可-> 联系客服 投诉资源
www.panoramacn.com资源全部来自互联网收集,仅供用于学习和交流,请勿用于商业用途。如有侵权、不妥之处,请联系站长并出示版权证明以便删除。 敬请谅解! 侵权删帖/违法举报/投稿等事物联系邮箱:2640602276@qq.com
未经允许不得转载:书荒源码源码网每日更新网站源码模板! » VRRP实验——虚拟路由冗余协议
关注我们小说电影免费看
关注我们,获取更多的全网素材资源,有趣有料!
120000+人已关注
分享到:
赞(0) 打赏

评论抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

您的打赏就是我分享的动力!

支付宝扫一扫打赏

微信扫一扫打赏