【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册

来源:CSDN
作者:最铁头的网工 (全球首批HCIA-DATACOM认证者)
认证技术:关于HCIA-DATACOM认证技术知识会在我博客做持续更新。。。
本期分享:系列15点到16点半-技术热讯
感谢大家关注-最铁头的网工,请大家持续关注就可以了哦!关于进阶级手册在下方↓↓↓
众元教育-华为HCIA-DATACOM技术认证课:课程通道
众元教育-华为HCIA-DATACOM技术认证裙:414605852

1.1 实现VLAN间通信实验
1.1.1 实验介绍
1.1.1.1 关于本实验

划分VLAN后,不同VLAN的用户间不能二层互访,这样能起到隔离广播的作用。但实际应用中,不同VLAN的用户又常有互访的需求,此时就需要实现不同VLAN的用户互访,简称VLAN间互访。

华为提供了多种技术实现VLAN间互访,常用的两种技术为VLANIF 接口和Dot1q终结子接口。

Dotlq终结子接口:子接口也是一种三层的逻辑接口。跟VLANIF接口一样,在子接口上配置Dotlq终结功能和IP地址后,设备也会添加相应的MAC表项并置位三层转发标志位,进而实现VLAN间的三层互通。Dotlq终结子接口适用于通过一个三层以太网接口下接多个VLAN网络的环境。
VLANIF接口:VLANIF 接口是一种三层的逻辑接口。在VLANIF 接口上配置IP地址后,设备会在MAC地址表中添加VLANIF接口的MAC地址+VID表项,并且为表项的三层转发标志位置位。当报文的目的MAC地址匹配该表项后,会进行三层转发,进而实现VLAN间的三层互通。

1.1.1.2 实验目的

掌握通过配置Dot1q终结子接口方法实现VLAN间互访
掌握通过配置 VLANIF接口方法实现VLAN间互访
深入理解VLAN间互相访问的转发流程

1.1.1.3 实验组网介绍

【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册

实现VLAN间通信实验拓扑

PC1和PC2是终端用户,接口IP地址分别为192.168.2.1/24和192.168.3.1/24。

PC1和PC2的网关地址分别为192.168.2.254和192.168.3.254。

在S1上将GigabitEthernet0/0/2和GigabitEthernet0/0/3分别划入VLAN2和VLAN3。

1.1.1.4 实验背景

R2和R3处于不同的VLAN,现要求通过VLANIF 接口和Dot1q终结子接口分别实现R2与R3之间的互访需求。

1.1.2 实验任务配置
1.1.2.1 配置思路

1.配置Dot1q终结子接口方法实现VLAN间互访

2.配置VLANIF接口方法实现VLAN间互访

1.1.2.2配置步骤
步骤1设备基础配置

# 给R1和S1命名

[Huawei]sysname S1
[S1]

[Huawei]sysname R1
[R1]

# PC1和PC2的IP地址及网关配置

【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
#在S1上对PC1和PC2进行VLAN划分

[S1]vlan batch 2 3
Info: This operation may take a few seconds. Please wait for a moment...done.
[S1]interface GigabitEthernet 0/0/2
[S1-GigabitEthernet0/0/2]port link-type access
[S1-GigabitEthernet0/0/2]port default vlan 2
[S1]interface GigabitEthernet 0/0/3
[S1-GigabitEthernet0/0/3]port link-type access
[S1-GigabitEthernet0/0/3port default vlan 3

步骤2 通过Dot1q终结子接口实现VLAN间互访

# 配置S1上的Trunk接口

[S1]interface GigabitEthernet 0/0/1
[S1-GigabitEthernet0/0/1]port link-type trunk
[S1-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 3

因为VLAN间互访数据要由Rl来终结VLAN,所以Sl和Rl之间的链路要允许VLAN2和VLAN3通过。

# 在R1上创建并配置Dot1q终结子接口

[R1]interface  GigabitEthernet 0/0/1.2

创建并进入子接口视图。2代表子接口的编号,一般建议子接口编号与VLAN ID相同,方便记忆。

[R1-GigabitEthernet0/0/1.2]dot1q termination vid 2

dot1q termination vid vlan-id命令用来配置子接口Dot1 q终结的VLAN ID。
以此配置为例:当GigabitEthernetO/0/1接口收到带有VLAN 2标签的数据之后,会交由2号子接口进行VLAN终结操作并做后续处理。从2号子接口发出的数据也会带上VLAN 2的标签。

[R1-GigabitEthernet0/0/1.2]arp broadcast enable

终结子接口不能转发广播报文,在收到广播报文后它们直接把该报文丢弃。为了允许终结子接口能转发广播报文,可以通过在子接口上执行命令arp broadcast enable使能终结子接口的ARP广播功能。部分设备默认使能该功能,此命令的配置根据设备而定。

[R1-GigabitEthernet0/0/1.2]ip address 192.168.2.254 24
[R1-GigabitEthernet0/0/1.2]undo shutdown
[R1-GigabitEthernet0/0/1.2]quit
[R1]interface GigabitEthernet 0/0/1.3
[R1-GigabitEthernet0/0/1.3]dot1q termination vid 3
[R1-GigabitEthernet0/0/1.3]arp broadcast enable
[R1-GigabitEthernet0/0/1.3]ip address 192.168.3.254 24
[R1-GigabitEthernet0/0/1.3]undo shutdown
[R1-GigabitEthernet0/0/1.3]quit

# 检测VLAN间互访联通性
问题是?这个第一个包为什么会丢。。。
【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
此时VLAN2和VLAN3之间已经可以正常的互访。

步骤3通过VLANIF 接口实现VLAN间互访

# 清除上一步配置

[S1]interface  GigabitEthernet 0/0/1
[S1-GigabitEthernet0/0/1]undo port trunk allow-pass vlan 2 3
[S1-GigabitEthernet0/0/1]undo port link-type

[R1]undo interface GigabitEthernet 0/0/1.2
[R1]undo interface GigabitEthernet 0/0/1.3

# 在S1上创建相应的VLANIF接口

[S1]interface  Vlanif 2

interface vlanif vlan-id命令用来创建VLANIF接口并进入VLANIF接口视图。只有先通过命令创建VLAN后,才能执行interface vlanif命令创建VLANIF接口。

[S1-Vlanif2]ip address 192.168.2.254 24

[S1-Vlanif2]quit
[S1]interface Vlanif 3
[S1-Vlanif3]ip address 192.168.3.254 24
[S1-Vlanif3]quit

# 检测VLAN间互访联通性
【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
此时VLAN2和VLAN3之间已经可以正常的互访。

原创:https://www.panoramacn.com
源码网提供WordPress源码,帝国CMS源码discuz源码,微信小程序,小说源码,杰奇源码,thinkphp源码,ecshop模板源码,微擎模板源码,dede源码,织梦源码等。

专业搭建小说网站,小说程序,杰奇系列,微信小说系列,app系列小说

【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册

免责声明,若由于商用引起版权纠纷,一切责任均由使用者承担。

您必须遵守我们的协议,如果您下载了该资源行为将被视为对《免责声明》全部内容的认可-> 联系客服 投诉资源
www.panoramacn.com资源全部来自互联网收集,仅供用于学习和交流,请勿用于商业用途。如有侵权、不妥之处,请联系站长并出示版权证明以便删除。 敬请谅解! 侵权删帖/违法举报/投稿等事物联系邮箱:2640602276@qq.com
未经允许不得转载:书荒源码源码网每日更新网站源码模板! » 【华为认证】HCIA-DATACOM技术分享-配置VLAN间通信实验,通过dot1q子接口实现-入门级手册
关注我们小说电影免费看
关注我们,获取更多的全网素材资源,有趣有料!
120000+人已关注
分享到:
赞(0) 打赏

评论抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

您的打赏就是我分享的动力!

支付宝扫一扫打赏

微信扫一扫打赏